SUMMA.OMF eller SUMMA.OM: Vilken skall man välja

Både SUMMA.OM och SUMMA.OMF används för att summera värden i Excel baserat på villkor, men de har vissa viktiga skillnader. Här förklar jag hur SUMMA.OMF fungerar och reder jag ut skillnaderna till SUMMA.OM och varför du hädanefter helt kan skippa att använda SUMMA.OM.

Introduktion till SUMMA.OM

SUMMA.OM är en funktion som tillåter användaren att summera värden i ett intervall baserat på ett givet villkor. Det är särskilt användbart i situationer där du behöver summera tal baserat på ett enda kriterium.

Notera att det som jag visar med SUMMA.OMF här även ser likadant med funktionerna ANTAL.OMF och MEDELOM.F. Det vill säga med ANTAL.OMF kan du räkna hur många celler det finns i ett område som uppfyller ett eller flera villkor och med MEDEL.OMF kan du beräkna medelvärdet för ett område som uppfyller ett eller flera villkor.

Syntax:

SUMMA.OM(område; villkor; [summaområde])

  • område: De celler som villkoret tillämpas på.
  • villkor: Det kriterium som måste uppfyllas för att en cell ska inkluderas i summan.
  • summaområde (valfritt): De faktiska värdena som ska summeras. Om detta argument utelämnas, summeras cellerna i ”område”.

Exempel:

Anta att du I kolumn A har en lista över sålda produkter och i kolumn B försäljningssumma. Antag att du nu vill summera den totala försäljningen för produkten ”XYZ” som är en av de produkter som listas i kolumn A . Med SUMMA.OM skulle funktionen kunna se ut så här:

=SUMMA.OM(A2:A100; ”XYZ”; B2:B100)

Denna funktion summerar värdena i området B2:B100 för de rader där ”XYZ” förekommer i kolumn A2:A100.

SUMMA.OMF

SUMMA.OMF kan göra precis samma sak som SUMMA.OM, med den stora skillnaden att du med SUMMA.OMF kan lägga till flera villkor.

Syntax

SUMMA.OMF(summaområde, villkorsområde1, villkor1, [villkorsområde2, villkor2], …)

  • summaområde: Det cellintervall som ska summeras.
  • villkorsområde1: Det intervall som testas med Villkor1.
  • villkor1: (valfritt): Det villkor som anger vilka celler i Villkorsområde1 som ska adderas. Villkor kan till exempel anges som 10, ”>10”, B4 eller ”Umeå”.
  • Villkorsområde1 och Villkor1 utgör ett sökpar som används för att granska ett visst intervall för att identifiera poster som uppfyller specifika kriterier. När dessa poster har identifierats summeras de motsvarande värdena från Summaområdet.
  • [villkorsområde2, villkor2] är valfria och kan utökas med ytterligare villkor.

Exempel:

Exempel 1: Med samma exempel som för SUMMA.OM skulle SUMMAOMF se ut så här:

=SUMMA.OMF(B2:B100; A2:A100; ”XYZ”)

Skillnade är att i SUMMAOMF kommer summaområdet (här B2:B100) först och därefter villkorsområdet (det om i SUMMA.OM bara heter ”område”).

Tre exempel på hur SUMMA.OMF kan användas

Jag utgår från nedanstånde arbetsbok där det finns ett dataset med fälten År, Avdelning, Kategori och Belopp.

Det finns tre avdelningar (Logistik, Försäljning och Marknadsföring), tre kategorier (Personal, Diverse och Elektronik) samt två år (2022 och 2023).

(detta är samma arbetsbok som jag använder i min film på YouTube och du kan ladda ner den via en länk längst ner på denna sida).

Formel 1 (röd ruta)

I G8 har jag formeln: =SUMMA.OM($B$3:$B$32;F8;$D$3:$D$32)

Här använder jag SUMMA.OM för att summera beloppen för avdelning logistik.

Formel 2 (gul ruta)

I H8 så har jag formeln: =SUMMA.OMF($D$3:$D$32;$B$3:$B$32;F8)

Här gör SUMMA.OMF samma sak som SUMMA.OM i G8. Notera skillnaden att i SUMMA.OMF kommer summaområdet först i argumentet.

Slutsats: Även om man bara har ett villkor så är SUMMA.OMF lika enkel som SUMMA.OM. Men det skapar mer flexibilitet för mer komplicerade problem. Om man bara använder SUMMA.OMF så kommer det vara lättare att lösa svårare problem då man inte behöver använda en annan formel som man inte känner till. Det är därför du skall sluta använda SOMMA.OM och bara arbeta med SUMMA.OMF!

Fomel 3 (blå ruta)

I cell K8 har jag formlen: =SUMMA.OMF($D$3:$D$32;$B$3:$B$32;$J$7;$C$3:$C$32;J8)

Här lägger jag till ett andra villkor och summar beloppen för respektive kategori, enbart för avdelning Logistik.

Formel 4 (grön ruta)

I cell G16 har jag formeln: =SUMMA.OMF($D$3:$D$32;$B$3:$B$32;$F$15;$C$3:$C$32;$F$16;$A$3:$A$32;G15)

Den består av tre villskorsmråden och villkor:

  • Villkorsområde 1: $B$3:$B$32, VIllkor 1: $F$15 (avdelning)
  • Villkorsområde 2: $C$3:$C$32, VIllkor 2: $F$16 (kategori)
  • Villkorsområde 3: $A$3:$A$32, VIllkor 3: G15 (år)

Notera absoluta och relativa referenser

I mina exempel byter jag mellan absoluta och relativa referenser beroende på hur jag vill kopiera formeln. Jag använder snabbkommandot F4 (cmd+T på Mac) för att snabbt växla mellan dessa. Om en funktion inte ska kopieras är det naturligtvis inget man behöver bry sig om.

Film: Upptäck kraften i SUMMA.OMF och varför du skall sluta använda SUMMA.OM

Se min film där jag jämför SUMMA.OM med SUMMA.OMF och visar steg för steg hur man kan lägga till fler villkor till SUMMA.OMF:

Film: Filtrera datumintervall med SUMMA.OMF och nya funktionen SLUTMÅNAD

I nästa video videon dyker jag ner i mer kraftfulla tekniker för att filtrera och analysera data baserat på datum i Excel. Jag går bortom grundläggande filter och utforskar avancerade funktioner som SUMMA.OMF och den nya SLUTMÅNAD (EOMONTH) för att skapa effektiva rapporter och analyser.

Vad du kan lära dig från denna:

  • Filtrera och summera data baserat på specifika datumintervall med SUMMA.OMF (SUMIFS). Perfekt för månadsrapporter, försäljningsanalys och mer!
  • Skapa en serie med månader automatiskt med smarta formler.
  • Använd den nya Excelfunktionen SLUTMÅNAD (EOMONTH) för att beräkna sista dagen i en månad.
  • Formatera datum för att visa månadsnamn i stället för siffror.
  • Analysera data med pivottabeller – ett kraftfullt verktyg för att sammanfatta och analysera data.

Oavsett om du är en Excel-nybörjare eller en erfaren användare, kommer du att hitta värdefulla tips och tekniker i den här videon som kan ta din dataanalys till en ny nivå.

Min exempelfil

Ladda ner min exempelfil här (dropbox): SUMMAOMF.xlsx

Vad betyder ”F” is SUMMA.OMF, ANTAL.OMF och MEDEL.OMF?

Hur Microsoft väljer att översätta engelska funktioner till svenska är ibland ett mysterium. På engelska heter dessa funktioner SUMIFS, COUNTIFS och AVERAGEIFS – vilket känns mer logiskt. Det är helt enkelt IF i pluralis. One IF and multiple IFS. Så då SUMIF kan hantera ett IF, kan SUMIFS hantera flera IFS. En enkel killgissning är att ”F” helt enkelt står för ”Flera” (villkor). Men jag har egentligen ingen aning.

Mer resurser

Tycker du det här med datum och tid är krångligt i Excel så kan min bloggpost där jag reder ut detta hjälpa: https://www.andersexcel.se/rakna-med-tid-excel/

se även microsofts hjälpsida om SUMMA.OMF

(Visited 227 times, 1 visits today)

2 comments

  • Georg Schwarz

    Hej,
    Bra pedagogiskt innehåll men saknar svar på en fråga. Kan SUMMA.OMF hantera villkor beroende på hur cellen är formulerad. Har en excelfil där konsulters arbetstid redovisas. Varje rad består av konsultens namn samt kolumner för varje dag. I vit ruta står tid som konsulten är inplanerad, i grön ruta står inplanerad tid som fakturerats och i röd ruta står inplanerad tid men där konsulten varit sjuk/frånvarande. Skulle vilja kunna summera de tre olika varianterna av tid för att t.ex. kunna se hur mycket projekttid som använts respektive planerats in. Har även försökt använda celltyp, bra, dålig och neutral men inte hittat någon lösning där heller. Finns det någon lösning på problemet?

    • Tyvärr kan SUMMA.OMF inte hantera villkor baserat på cellens formatering, som färg. För att lösa detta kan du använda VBA (Visual Basic for Applications) för att skapa en egen funktion som summerar värden baserat på cellfärg (men vet inte om jag kan rekommendera det.)
      Här är också en annan lösning som kanske kan hjälpa:
      https://www.myexcelonline.com/blog/excel-if-cell-color-is-green/
      Vad man behöver är någon form av funktion som returnerar ett värde som styrs av färgen i cellen. Får man ett sådan kan man sedan använda detta villkor som värde i SUMMA.OMF.
      Mvh
      Anders

Lämna ett svar

Din e-postadress kommer inte publiceras. Obligatoriska fält är märkta *

Denna webbplats använder Akismet för att minska skräppost. Lär dig hur din kommentardata bearbetas.